# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[url]https:\\/\\/(?:www\.)*+youtube\.com\\/watch\?v=([\w\-]+)\[\\/url\]/[media=youtube]\1[\/media]/Uis;t' <<< "[url]https://www.youtube.com/watch?v=hXxQhbmjE7o[/url]"