// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))").unwrap();
let string = "```import test```
hello;
hello;
hello;
```return test```
`import test`
hello;
hello;
hello;
return test```
`from test import test`
hello;
hello;
hello;
return test```
import test
hello;
hello;
hello;
return test```
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}