using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))";
string input = @"```import test```
hello;
hello;
hello;
```return test```
`import test`
hello;
hello;
hello;
return test```
`from test import test`
hello;
hello;
hello;
return test```
import test
hello;
hello;
hello;
return test```
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}