$re = '/(```|`)(python)?\s*?\n?(from \S+ )?import \S+(\n.*?;)*\n((.*return \S+```)|(`return \S+`))/m';
$str = '```import test```
hello;
hello;
hello;
```return test```
`import test`
hello;
hello;
hello;
return test```
`from test import test`
hello;
hello;
hello;
return test```
import test
hello;
hello;
hello;
return test```
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);