import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(```|`)(python)?\\s*?\\n?(from \\S+ )?import \\S+(\\n.*?;)*\\n((.*return \\S+```)|(`return \\S+`))";
final String string = "```import test```\n"
+ "hello;\n"
+ "hello;\n"
+ "hello;\n"
+ "```return test```\n\n"
+ "`import test`\n"
+ "hello;\n"
+ "hello;\n"
+ "hello;\n"
+ "return test```\n\n"
+ "`from test import test`\n"
+ "hello;\n"
+ "hello;\n"
+ "hello;\n"
+ "return test```\n\n"
+ "import test\n"
+ "hello;\n"
+ "hello;\n"
+ "hello;\n"
+ "return test```\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}