const regex = new RegExp('(```|`)(python)?\\s*?\\n?(from \\S+ )?import \\S+(\\n.*?;)*\\n((.*return \\S+```)|(`return \\S+`))', 'gm')
const str = `\`\`\`import test\`\`\`
hello;
hello;
hello;
\`\`\`return test\`\`\`
\`import test\`
hello;
hello;
hello;
return test\`\`\`
\`from test import test\`
hello;
hello;
hello;
return test\`\`\`
import test
hello;
hello;
hello;
return test\`\`\`
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}