// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([A-z.]{3,9}|[0-9]{1,2}) [0-9]{1,2}[, ]{1,2}[0-9]{1,4})|(([A-z.]{3,9}|[0-9]{1,2})[ ,][0-9]{1,4})|([0-9]{1,4})").unwrap();
let string = "May 5, 2010
2010
Mar. 1990
5 1990";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}