package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([A-z.]{3,9}|[0-9]{1,2}) [0-9]{1,2}[, ]{1,2}[0-9]{1,4})|(([A-z.]{3,9}|[0-9]{1,2})[ ,][0-9]{1,4})|([0-9]{1,4})`)
var str = `May 5, 2010
2010
Mar. 1990
5 1990`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}