#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([A-z.]{3,9}|[0-9]{1,2}) [0-9]{1,2}[, ]{1,2}[0-9]{1,4})|(([A-z.]{3,9}|[0-9]{1,2})[ ,][0-9]{1,4})|([0-9]{1,4})"
Local $sString = "May 5, 2010" & @CRLF & _
"2010" & @CRLF & _
"Mar. 1990" & @CRLF & _
"5 1990"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")