using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([A-z.]{3,9}|[0-9]{1,2}) [0-9]{1,2}[, ]{1,2}[0-9]{1,4})|(([A-z.]{3,9}|[0-9]{1,2})[ ,][0-9]{1,4})|([0-9]{1,4})";
string input = @"May 5, 2010
2010
Mar. 1990
5 1990";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}