# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?P<series_name>.+?)[. _-]+)?s(?P<season_num>\d+)[. _-]*e(?P<ep_num>\d+)(([. _-]*e|-)(?P<extra_ep_num>(?!(1080|720|480)[pi])\d+))*[. _-]*((?P<extra_info>.+?)((?<![. _-])(?<!WEB)-(?P<release_group>[^- ]+([. _-]\[.*\])?))?)? "
test_str = "130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.nzb, /home/roland/Downloads/incomplete/130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.1"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.