const regex = /((?P<series_name>.+?)[. _-]+)?s(?P<season_num>\d+)[. _-]*e(?P<ep_num>\d+)(([. _-]*e|-)(?P<extra_ep_num>(?!(1080|720|480)[pi])\d+))*[. _-]*((?P<extra_info>.+?)((?<![. _-])(?<!WEB)-(?P<release_group>[^- ]+([. _-]\[.*\])?))?)? /;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?P<series_name>.+?)[. _-]+)?s(?P<season_num>\\d+)[. _-]*e(?P<ep_num>\\d+)(([. _-]*e|-)(?P<extra_ep_num>(?!(1080|720|480)[pi])\\d+))*[. _-]*((?P<extra_info>.+?)((?<![. _-])(?<!WEB)-(?P<release_group>[^- ]+([. _-]\\[.*\\])?))?)? ', '')
const str = `130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.nzb, /home/roland/Downloads/incomplete/130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}