import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?P<series_name>.+?)[. _-]+)?s(?P<season_num>\\d+)[. _-]*e(?P<ep_num>\\d+)(([. _-]*e|-)(?P<extra_ep_num>(?!(1080|720|480)[pi])\\d+))*[. _-]*((?P<extra_info>.+?)((?<![. _-])(?<!WEB)-(?P<release_group>[^- ]+([. _-]\\[.*\\])?))?)? ";
final String string = "130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.nzb, /home/roland/Downloads/incomplete/130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}