use strict;
my $str = '130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.nzb, /home/roland/Downloads/incomplete/130853-FULL-a.b.teevee-Utopia.S01E01.Proper.720p.BluRay.X264-7SinS-0183-7s-utopia-s01e01-720p.nfo.1';
my $regex = qr/((?P<series_name>.+?)[. _-]+)?s(?P<season_num>\d+)[. _-]*e(?P<ep_num>\d+)(([. _-]*e|-)(?P<extra_ep_num>(?!(1080|720|480)[pi])\d+))*[. _-]*((?P<extra_info>.+?)((?<![. _-])(?<!WEB)-(?P<release_group>[^- ]+([. _-]\[.*\])?))?)? /p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}