# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?\d{1,3}(?:(?:,\d{3}){0,4}(?:\.\d{1,2})|(?:(?:\s\d{3}){0,4}|(?:\d{0,12}))(?:[.,]\d{1,2})?)$"
test_str = ("123456\n"
"123456.12\n"
"123456,00\n"
"123,456.12\n"
"123,456,12\n"
"123 456.12\n"
"123,456,12\n"
"123,456,123,123,123.00\n\n"
"123,456.123\n"
"123 456,789.12")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.