use strict;
my $str = '123456
123456.12
123456,00
123,456.12
123,456,12
123 456.12
123,456,12
123,456,123,123,123.00
123,456.123
123 456,789.12';
my $regex = qr/^-?\d{1,3}(?:(?:,\d{3}){0,4}(?:\.\d{1,2})|(?:(?:\s\d{3}){0,4}|(?:\d{0,12}))(?:[.,]\d{1,2})?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}