const regex = /^-?\d{1,3}(?:(?:,\d{3}){0,4}(?:\.\d{1,2})|(?:(?:\s\d{3}){0,4}|(?:\d{0,12}))(?:[.,]\d{1,2})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?\\d{1,3}(?:(?:,\\d{3}){0,4}(?:\\.\\d{1,2})|(?:(?:\\s\\d{3}){0,4}|(?:\\d{0,12}))(?:[.,]\\d{1,2})?)$', 'gm')
const str = `123456
123456.12
123456,00
123,456.12
123,456,12
123 456.12
123,456,12
123,456,123,123,123.00
123,456.123
123 456,789.12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}