#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d{1,3}(?:(?:,\d{3}){0,4}(?:\.\d{1,2})|(?:(?:\s\d{3}){0,4}|(?:\d{0,12}))(?:[.,]\d{1,2})?)$"
Local $sString = "123456" & @CRLF & _
"123456.12" & @CRLF & _
"123456,00" & @CRLF & _
"123,456.12" & @CRLF & _
"123,456,12" & @CRLF & _
"123 456.12" & @CRLF & _
"123,456,12" & @CRLF & _
"123,456,123,123,123.00" & @CRLF & _
"" & @CRLF & _
"123,456.123" & @CRLF & _
"123 456,789.12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")