$re = '/^-?\d{1,3}(?:(?:,\d{3}){0,4}(?:\.\d{1,2})|(?:(?:\s\d{3}){0,4}|(?:\d{0,12}))(?:[.,]\d{1,2})?)$/m';
$str = '123456
123456.12
123456,00
123,456.12
123,456,12
123 456.12
123,456,12
123,456,123,123,123.00
123,456.123
123 456,789.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);