re = /(pa)(?!([^<]+)?>)/m
str = '\'The pattern to <span class="something">be replaced is pa but only outside the html tag</span>\''
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result