const regex = /(pa)(?!([^<]+)?>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(pa)(?!([^<]+)?>)', 'gm')
const str = `'The pattern to <span class="something">be replaced is pa but only outside the html tag</span>'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);