using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(pa)(?!([^<]+)?>)";
string substitution = @"";
string input = @"'The pattern to <span class=""something"">be replaced is pa but only outside the html tag</span>'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}