use strict;
my $str = '\'The pattern to <span class="something">be replaced is pa but only outside the html tag</span>\'';
my $regex = qr/(pa)(?!([^<]+)?>)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";