$re = '/(pa)(?!([^<]+)?>)/m';
$str = '\'The pattern to <span class="something">be replaced is pa but only outside the html tag</span>\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;