// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)").unwrap();
let string = "123
9876456000
123456789
91370
111
415263
xyz123xyz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}