using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)";
string input = @"123
9876456000
123456789
91370
111
415263
xyz123xyz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}