#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)"
Local $sString = "123" & @CRLF & _
"9876456000" & @CRLF & _
"123456789" & @CRLF & _
"91370" & @CRLF & _
"" & @CRLF & _
"111" & @CRLF & _
"415263" & @CRLF & _
"xyz123xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")