const regex = /(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)', 'g')
const str = `123
9876456000
123456789
91370
111
415263
xyz123xyz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}