$re = '/(012)|(123)|(234)|(345)|(456)|(567)|(678)|(789)/';
$str = '123
9876456000
123456789
91370
111
415263
xyz123xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);