re = /\$\{(?!p\.)([^}]*?\.(?:description|input|label))\}/
str = '${person.label} ${taco.input} ${person.description}
${p.person.label} ${taco.something} ${test-dash.description} ${test_underscore.input} ${999.label}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end