#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$\{(?!p\.)([^}]*?\.(?:description|input|label))\}"
Local $sString = "${person.label} ${taco.input} ${person.description}" & @CRLF & _
"${p.person.label} ${taco.something} ${test-dash.description} ${test_underscore.input} ${999.label}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")