using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\{(?!p\.)([^}]*?\.(?:description|input|label))\}";
string input = @"${person.label} ${taco.input} ${person.description}
${p.person.label} ${taco.something} ${test-dash.description} ${test_underscore.input} ${999.label}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}