const regex = /\$\{(?!p\.)([^}]*?\.(?:description|input|label))\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\{(?!p\\.)([^}]*?\\.(?:description|input|label))\\}', 'g')
const str = `\${person.label} \${taco.input} \${person.description}
\${p.person.label} \${taco.something} \${test-dash.description} \${test_underscore.input} \${999.label}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}