$re = '/\$\{(?!p\.)([^}]*?\.(?:description|input|label))\}/';
$str = '${person.label} ${taco.input} ${person.description}
${p.person.label} ${taco.something} ${test-dash.description} ${test_underscore.input} ${999.label}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);