// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^.*\/(.*?.xls)$").unwrap();
let string = "http://vcu.edu.vn/vi/adminaspx/filesupload/DANH%20SACH%20DANG%20KY_12.xls";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}