package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*\/(.*?.xls)$`)
var str = `http://vcu.edu.vn/vi/adminaspx/filesupload/DANH%20SACH%20DANG%20KY_12.xls`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}