re = /^.*\/(.*?.xls)$/
str = 'http://vcu.edu.vn/vi/adminaspx/filesupload/DANH%20SACH%20DANG%20KY_12.xls'
# Print the match result
str.match(re) do |match|
puts match.to_s
end