using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\/(.*?.xls)$";
string input = @"http://vcu.edu.vn/vi/adminaspx/filesupload/DANH%20SACH%20DANG%20KY_12.xls";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}