const regex = /^.*\/(.*?.xls)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\\/(.*?.xls)$', '')
const str = `http://vcu.edu.vn/vi/adminaspx/filesupload/DANH%20SACH%20DANG%20KY_12.xls`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}