import Foundation
let pattern = #"((([0-9a-fxA-FX]){2})(?|[,\n])){8,16}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiKey\Dumps\D9DA0000]
"DongleType"=dword:00000003
"Copyright"="None"
"Created"="Tue Jan 08 10:33:00.496 2013" by dmp2mkey
"Name"="D9DA Sentinel SuperPro Dump"
"Type"=dword:00000000
"CellType"=hex:\
01,01,03,03,03,01,03,01,\
03,03,00,00,00,00,00,00,\
00,00,00,00,01,00,00,01,\
00,00,01,00,00,01,00,00,\
00,00,00,00,00,00,00,00,\
00,01,00,00,00,00,00,00,\
00,00,01,00,00,00,00,00,\
00,00,00,00,00,00,00,00
"sntMemory"=hex:\
01,1A,DA,D9,00,00,00,00,EF,5D,01,00,DE,59,11,00,\
31,FA,A0,F0,00,00,00,00,F0,55,00,00,F0,55,00,00,\
F0,55,00,00,F0,55,47,00,01,00,FF,00,01,00,FF,00,\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)