const regex = /((([0-9a-fxA-FX]){2})(?|[,\n])){8,16}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((([0-9a-fxA-FX]){2})(?|[,\\n])){8,16}', 'gm')
const str = `Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\MultiKey\\Dumps\\D9DA0000]
"DongleType"=dword:00000003
"Copyright"="None"
"Created"="Tue Jan 08 10:33:00.496 2013" by dmp2mkey
"Name"="D9DA Sentinel SuperPro Dump"
"Type"=dword:00000000
"CellType"=hex:\\
01,01,03,03,03,01,03,01,\\
03,03,00,00,00,00,00,00,\\
00,00,00,00,01,00,00,01,\\
00,00,01,00,00,01,00,00,\\
00,00,00,00,00,00,00,00,\\
00,01,00,00,00,00,00,00,\\
00,00,01,00,00,00,00,00,\\
00,00,00,00,00,00,00,00
"sntMemory"=hex:\\
01,1A,DA,D9,00,00,00,00,EF,5D,01,00,DE,59,11,00,\\
31,FA,A0,F0,00,00,00,00,F0,55,00,00,F0,55,00,00,\\
F0,55,00,00,F0,55,47,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}