// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((([0-9a-fxA-FX]){2})(?|[,\n])){8,16}").unwrap();
let string = "Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\MultiKey\\Dumps\\D9DA0000]
\"DongleType\"=dword:00000003
\"Copyright\"=\"None\"
\"Created\"=\"Tue Jan 08 10:33:00.496 2013\" by dmp2mkey
\"Name\"=\"D9DA Sentinel SuperPro Dump\"
\"Type\"=dword:00000000
\"CellType\"=hex:\\
01,01,03,03,03,01,03,01,\\
03,03,00,00,00,00,00,00,\\
00,00,00,00,01,00,00,01,\\
00,00,01,00,00,01,00,00,\\
00,00,00,00,00,00,00,00,\\
00,01,00,00,00,00,00,00,\\
00,00,01,00,00,00,00,00,\\
00,00,00,00,00,00,00,00
\"sntMemory\"=hex:\\
01,1A,DA,D9,00,00,00,00,EF,5D,01,00,DE,59,11,00,\\
31,FA,A0,F0,00,00,00,00,F0,55,00,00,F0,55,00,00,\\
F0,55,00,00,F0,55,47,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}