#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((([0-9a-fxA-FX]){2})(?|[,\n])){8,16}"
Local $sString = "Windows Registry Editor Version 5.00" & @CRLF & _
"[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\MultiKey\Dumps\D9DA0000]" & @CRLF & _
""DongleType"=dword:00000003" & @CRLF & _
""Copyright"="None"" & @CRLF & _
""Created"="Tue Jan 08 10:33:00.496 2013" by dmp2mkey" & @CRLF & _
""Name"="D9DA Sentinel SuperPro Dump"" & @CRLF & _
""Type"=dword:00000000" & @CRLF & _
""CellType"=hex:\ " & @CRLF & _
" 01,01,03,03,03,01,03,01,\ " & @CRLF & _
" 03,03,00,00,00,00,00,00,\ " & @CRLF & _
" 00,00,00,00,01,00,00,01,\ " & @CRLF & _
" 00,00,01,00,00,01,00,00,\ " & @CRLF & _
" 00,00,00,00,00,00,00,00,\ " & @CRLF & _
" 00,01,00,00,00,00,00,00,\ " & @CRLF & _
" 00,00,01,00,00,00,00,00,\ " & @CRLF & _
" 00,00,00,00,00,00,00,00" & @CRLF & _
""sntMemory"=hex:\ " & @CRLF & _
" 01,1A,DA,D9,00,00,00,00,EF,5D,01,00,DE,59,11,00,\ " & @CRLF & _
" 31,FA,A0,F0,00,00,00,00,F0,55,00,00,F0,55,00,00,\ " & @CRLF & _
" F0,55,00,00,F0,55,47,00,01,00,FF,00,01,00,FF,00,\" & @CRLF & _
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\" & @CRLF & _
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\" & @CRLF & _
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\" & @CRLF & _
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\" & @CRLF & _
" 01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")