use strict;
my $str = 'Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\MultiKey\\Dumps\\D9DA0000]
"DongleType"=dword:00000003
"Copyright"="None"
"Created"="Tue Jan 08 10:33:00.496 2013" by dmp2mkey
"Name"="D9DA Sentinel SuperPro Dump"
"Type"=dword:00000000
"CellType"=hex:\\
01,01,03,03,03,01,03,01,\\
03,03,00,00,00,00,00,00,\\
00,00,00,00,01,00,00,01,\\
00,00,01,00,00,01,00,00,\\
00,00,00,00,00,00,00,00,\\
00,01,00,00,00,00,00,00,\\
00,00,01,00,00,00,00,00,\\
00,00,00,00,00,00,00,00
"sntMemory"=hex:\\
01,1A,DA,D9,00,00,00,00,EF,5D,01,00,DE,59,11,00,\\
31,FA,A0,F0,00,00,00,00,F0,55,00,00,F0,55,00,00,\\
F0,55,00,00,F0,55,47,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00,\\
01,00,FF,00,01,00,FF,00,01,00,FF,00,01,00,FF,00
';
my $regex = qr/((([0-9a-fxA-FX]){2})(?|[,\n])){8,16}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}