// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(^[^a-z\._\\])|(\s)|.{256,}|[^a-z0-9_\._\\]|([a-z]{1,2})[0-9]+|^[rc]$").unwrap();
let string = "_10Q";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}