re = /(^[^a-z\._\\])|(\s)|.{256,}|[^a-z0-9_\._\\]|([a-z]{1,2})[0-9]+|^[rc]$/mi
str = '_10Q'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end