using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^a-z\._\\])|(\s)|.{256,}|[^a-z0-9_\._\\]|([a-z]{1,2})[0-9]+|^[rc]$";
string input = @"_10Q";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}