package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(^[^a-z\._\\])|(\s)|.{256,}|[^a-z0-9_\._\\]|([a-z]{1,2})[0-9]+|^[rc]$`)
var str = `_10Q`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}