$re = '/(^[^a-z\._\\\\])|(\s)|.{256,}|[^a-z0-9_\._\\\\]|([a-z]{1,2})[0-9]+|^[rc]$/mi';
$str = '_10Q';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);