re = /(?'first'.+\s)(\k'first')/m
str = 'שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result